Gene Modeling Tutorial using Artemis

We are working on gene structures for Ichthyophthirius multifilliis G5, or “Ich” —a parasite that afflicts fish. Ichis a
ciliate. Ciliates use a different codon set for stop codons; TGA is the only codon encoding a ‘stop’ in ciliates, unlike the

universal codons of TGA, TAG, TAA, which most organisms use.

Introduction: Modeling genes in Artemis

We know from our experience working with the various kinds of evidence that some are more reliable than others. In
our experience with Ich, we trust them in this order: transcripts & Training set >> TTA1_gw > paramecium > oxytricha
& glimmerHMM > genezilla > augustus.

We ran Evidence modeler (EVM) after we ran genefinders, protein alignments and PASA. EVM combined the evidence
using this ranking scheme, via its weights file:

TRANSCRIPT  alignAssembly-imgl 122008 pasa 20

PREDICTION  Train 20
PROTEIN genewise-Paramecium_peptide_vl.fa 7
PROTEIN genewise-oxytricha_all.fasta 6
PROTEIN genewise-TTAl.pep 8
PREDICTION augustus 4
PREDICTION  genezilla 5
PREDICTION  glimmerHMM 6

The output of EVM is a series of gff3 files containing the evidence for each scaffold. EVM is the automated gene
prediction for each locus. We will now examine these gene predictions in Artemis, and model some genes.

SECTION I. Open and configure Artemis.

Open Artemis: Using The Artemis link in course_links,

Artemis:; DNA sequence viewer and annotation tool
Introduction bring up the Artemis page at the Sanger Institute.

Locate the link to the Java Web Start version of Artemis.

Click on the link [outlined in red in the graphic), and a

Togeta copy of the currmet stable release of Aremis go to the Release 11 web pages.

System Requirements T Welcome screen will come up.
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For installation instructions please see the manual.
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Setting up the options

The Artemis Welcome screen has 3 menu items: File, Options, and Windows.

Open up the Ich scaffold sequence in Artemis

¥ Artemis Release 11.3.1

File Options Windows

me Trust
nstitute

Artenis
Release 11.3.1
6. Ciliate Dasycladacean and Hexamita

Copyright 1998 - 2009

Open Options menu, check the box next to ”6.
Ciliate Dasycladacean and Hexamita”

Also click on the “Set working directory” option
in the Options menu, near the end of the
options list. Set the working directory to your
flash drive’s data directory.

Open the File menu, and click on “Open...”

4

Options ‘ Windows

: Gene Modeling Tutorial

Re-read Options
| ¥ Enable Direct Editing

| --- Genetic Codes Tables ---
O 1. Standard

J 2. Vertebrate Mitochondrial
3. Yeast Mitochondrial

[J'5. Invertebrate Mitochondrial

,z 6. Ciliate Dasycladacean and Hexamita
{0 9. Echinodern Flatworn Mitochondrial

[0 10. Euplotid

D 11. Bacterial and Plant Plastid

[J12. Alternative Yeast Nuclear

[0 13. Ascidian Mitochondrial

J14. Alternative Flatworm Mitochondrial

[J15. Blepharisma Nuclear

[ 16. Chlorophycean Mitochondrial

J 21. Trematode Mitochondrial

I3 22. Scenedesmus Obliquus Mitochondrial

-1 23. Thraustochytrium Mitochondrial

"] Send Searches wvia 35H

[ 4. Mold, Protozoan, Coelenterate Mitochondrial and Mycoplasma/Spiroplasma

{[J Auto hide scrollbar

\ [J Highlight Active Entry

{ Look and Feel

A window labeled “Select a file...” will open.

The first line reads “Look In: and has a menu with a directory. Make sure it is pointing to your data directory.

The last line reads “Files of Type:”—Select “All Files”.

Find the file “genome.fasta” in your data directory. Selectit. Click the “Open” button.

This will bring up the Artemis viewer. Across the top are the following menus:

File, Entries, Select, View, Goto, Edit, Create, Run, Graph, Display.

SECTION lI: Entering the evidence

We will now open up the GFF3 files containing results of our searches and alignments:

Open, in order, each of the following:

1)
2)
3)
4)
5)
6)
7)
8)
9)

augustus.gff3
genezilla.gff3
glimmer.gff3
oxy_gw.gff3
para_gw.gff3
TTA1 gw.gff3
evm.gff3
PASA.gff3

entry...”

Open the File menu in the Artemis viewer,
and choose the second line, “Read an

Change “Files of Type:” to All Files.

Train.gff3



JCVI Eukaryotic Genome Annotation and Analysis Course: Gene Modeling Tutorial

Using Artemis

You now have all of the evidence generated by genefinders, spliced protein alignments, and PASA loaded into Artemis.

e Put each kind of evidence on its own line.

Entry: (V] genone. fasta [v] augustus.gfe3 (V] genezilla.gts [v] glinmerH. gee3 (V] oxycricha gv.gft3 [v]parameciun gw.gt3 (VI TTAL gv.gfe3 [V evn.gfe3 [v] transcripts.gfes
Nothing selected

Create

mOlE
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evm.nodel.1316.2 .
I | sy ey T N T e (i 1 N IR R /A= R U NN N A = S A TN R IR AR
Set Score Cutoffs ... evm.model,1316.2 CDS
[— ) LI I = 11 0l .
a5 of_1316.1000024, 035, of_1316.a000024 316000031, 1316. 6000032, 1316. €000033, 1316. 000034, L316. 000035, 1316  €000036 ‘ One line per entry
Zoom to Selection evise genezilla model 1316.u000024 2 1.pep. 1828366 i6 828366 1897 .fa.1792962 matc match.genewise.TTAL.pep. 1828376 3 =
fooo [ ls20o 2000 aoo ceoo cano 1200 eoso se00 seoo Lo |
Select Visible Features ‘ A” f t f I
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View ,
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As a matter of preference, you might

. N g Y ¢ L | Rm Y FLgKFHCYLIINIEKHEKLIFINILYIFERKYEKIOQNNYYS FLS IHNRK K

TAATTAKTATTAACTCT] ATTTTTTATAMAAATTTCATTGTTATT (TTANTATTTATAAATTTATATATTTTTARAGTT: TATTATAGTTTTT
scart codons f eo oo 10 120 a0 60
|KTTTANTTATARTTGAGA|  Stop Codons TTTTT: TATT TAKTTATAAATATTT, TTTCAATTTTAGGTTTTAT C”Ck on:
L W I N V R|¥Feature Arrovs WEKIFIENSNDNLLLYGqVYILIgqLHNIYKGgqLGgqFGFYEHNHNGYSHNEKILEYTI .
F 4 Y a4 5 W Feature Borders HEKEKYFN*QqKITIFILCLHNTINTIFEKYTIKLTLIUFLGQgqLlEKEKDEFL
£ I K gL FKHNTIqY YINFHRFqQYKYIqINEKEFNFDLIIIITERG F*TIF

¥ Feature Labels

<1 One Line Per Entry

& Feature labels

¥ Forvard Frame Lines
¥ Reverse Frame Lines

¥1 ALl Features On Frame Lines

[ Show Source Features >

Coloring tracks (optional)

You might wish to color the tracks so you can easily distinguish them.

To choose only one track at a time, so each has a different color, you must uncheck all of the others on the Entry menu
or on the Entry bar, which is immediately below the main menu. For example, uncheck everything except

“augustus.gff3”.

Then, on the Select menu, click on “All”.
Right-clicking anywhere inside the viewer will bring up a

menu.
A box will pop up. The box is shown below.
Undo Crrl-u
B Addor replace qualifiers of: EVM prediction 1316.1, cds_of_ev... [EJEX)
Selected Features in Editor Ctrl-E Insert qualifier: ‘ coLor] "
Subsequence (and Features)
/Dbxref= P
Find/Replace Qualifier Text ... [EC_number
“ﬁ smallest Features In Front Mg iieiar of Selected Feature(s) » Change ... colox
1
Set Score Cutoffs ... Selected Feature(s) »| Remove ... ::l;'zpdde onain
Raise Selected Fean =
fiee neested Teatures Move Selected Features To »| comvert ... lbrivate
MhEers SENCEERE e B Cooeead Fenemos T » stop_codon_redefined as_selenocysteine
BEU D3 Zoom to Selection (RIS M TN
K IS5 Select Visible Range Trim Selected Features »lg L L g F
G Ui o Extend Selected Features pllif & ¥ & &
badaaiTricar  Select Visible Features ¥ v oy v D
Fix $top Codons
ko Fraue Line Features ...
TITITABAGTA ,| hutonatically Create Gene Nemes ATTAATAATATCAAY
ER IR ERR ] )| Fix Gene Hemes RN ERTARE|
F N * Select 5 'qul.K
L F K M| View y| Pases I 11T
Goto »| Contig Reordering
Edit »| Header Of Default Entry Replace Add Close
Create »
Write > ‘ ‘ H
Choose ‘color ‘ from the pull-down menu and click the
“« e » .. .
“pdi” Insert qualifier” button. This inserts the line:
- Choose “Edit”, then q
“« s _
- Choose “Qualifier of Selected Feature(s), then /color=

- Choose “Change ...” Now, type: 100 149 237 [the code for Cornflower Blue.}
The line is now: /color= 100 149 237
Click “Replace” then “Close”.

All of the augustus predictions should have turned blue.
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Repeat this procedure for each color change. Here are

some RGB color codes: Indian Red 205 92 92

Orange 255 165 0
Forest Green 34 139 34 Red 255 0 0
Dark Khaki 189 183 107 Orchid 218 112 214
Cyan 0 255 255 Purple 160 32 240
Yellow 255 255 0 Gray 190 190 190
Goldenrod 218 165 32 Brown 139 119 101

Your result might look something like this:

£ Artemis Entry Edit: genome.fasta

File Entries Select View Goto Edit Create Run Graph Display

One selected base on forward strand: 13176
S

Entry: genome. fasta augqustus.gff3 genezilla.gff3 glimmerHMN. gf£3 oxytricha gw.gff3 paramecium_gw.gf£3 TTAL_gw.gff3 evm. gE£3 transcripts.gff3
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The separation and coloring of lines of evidence, while not necessary, make Artemis tracks much easier to interpret.

Section lll: Modeling genes

We have loaded lots of evidence into Artemis. The evidence included genefinder results, Genewise alignments of
protein sets, transcript assembly alignments, and a training set of genes. All of these were used by Evidence modeler
with the following weights:

TRANSCRIPT  alignAssembly-imgl_ 122008 pasa 20
PREDICTION  Train 20
PROTEIN genewise-Paramecium_peptide_vl.fa 7
PROTEIN genewise-oxytricha_all.fasta 6
PROTEIN genewise-TTAl.pep 8
PREDICTION  augustus 4
PREDICTION genezilla 5
PREDICTION glimmerHMM 6
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That is, the PASA transcripts and the training set had the most impact on the result, followed by Tetrahymena proteins,
etc. Keep in mind that in our experience with Ich, we judge the quality of the evidence in this order: transcripts &
Training set >> TTA1 gw > paramecium & glimmerHMM > oxytricha & glimmerHMM > genezilla > augustus. These
are reflected in EVM. EVM is the automated gene prediction for each locus. Examine these gene predictions, and
model some genes.

Model a gene

Set a default entry to save gene models to. Menu/Entries/Set Default Entry=>genes.gff3. Then, save it as a GFF file:
File/Save an Entry as... /GFF Format/genes.gff3. The program will ask if you want to overwrite the existing file. Say yes.

Zoom into the region 2000-9000. An easy way to do that is to click on the longest prediction in that region, and hit the

“n
z

key on your keyboard.

Next, drag your mouse from right to left in the positive direction above the coordinate line (above the numbers).
Menu/Create/Feature from Base Range (or Control-C). A window pops up:

> _ Arlemis Fealure Edit: CDS [x]
Key: [cDS - Add Qualifier: |note -

Location: |1951..8610
Complement | Grab Range | Remove Range | Goto Feature | Select Feature | TAT | ObjectEdit

0K Cancel Apply
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Click “Apply.”

Note that it has a line that says “Location:”. Your
coordinates will differ from those shown.

Decide on the structure of the gene you are about to model. Is there an EVM model?

fenezi

Vi wode T3i6.u00f7 T TT1 [ | 1NN
Bunno v evn. nooefevn. node. 1316.2 ]
5 )
atch.oenewise. TTALpep. 19 [atlidiuatch. oBhatdh. odhar ] latch. pahat)
patch. genewise. TTALpep. 16 jatdBvdinatch. odbatch. genewi ) latch. haat)

0 o leo P o o o foo B g0 o [0 B0 oo

You might notice that EVM predicts two genes in this space. Glimmer predicted one, and genewise matches in three
regions. What other evidence is there for the structure of this gene? Which is the best evidence, since there is no

transcript evidence?

Let’s model the longest gene predicted by EVM in this region first:
1) click on the first EVM predicted exon, with coordinates 4088 to 4286;
2) click on “Grab Range” and the Location line will change to join(1951..8610,4088..4286)
3) Now delete the first two numbers, leaving: join(4088..4286)
4) Click on the next exon, grab range, and the Location line will change to : join(4088..4286,4330..4405)
5) Proceed to grab each exon until the Location line reads: join(4088..4286,4330..4405,4461..4848,4893..5726)
6) Click the “Apply” button. Click “OK”.
Is this a good gene model? How do we know if it should include the exons that are upstream?

Check the gene model:
One way to gauge how to accurately model this gene is to use BLASTP. If your gene is not a unique gene, you may be
able to discern its correct boundaries based upon orthology. Bring up firefox. Go to the BLASTP page at NCBI.

Click on your new gene model, and choose “View/Amino Acids of Selection as FASTA” and copy the sequence that pops

up. Paste it into the text box on the BLASTP page.
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Mouse-over to show defline and scores, click to_show alignments

Color key for alignment scores
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Descriptions

This is an almost full-length match (84%) to a Tetrahymena thermophila protein, which is supported by a transcript. Itis
probably a real gene.

There is one start site just upstream of the start codon chosen by EVM. s this one a “better” choice? How would you
check?

Save your new gene model. Click on the new CDS, File/Save Default Entry (Ctrl-S).

Zoom in to the region on the forward strand at approximately 65kb. Choose the region approximately between 64kb
and 66kb on the forward strand. Drag your cursor over that region. While there is a yellow box from dragging,

Click the menu item ” Create”, then choose “Feature from Base Range ...”

The “Artemis Feature Edit: CDS” window will pop up. Under Location: you will see the coordinates that you swiped
across with your mouse.

Now, click on the PASA evidence in one of the tiers. Going back to the Feature edit window, click on “Grab Range”. The
coordinates of that exon are shown in the “join” statement:

join(64173..66333,64830..65583) [Your first two numbers will be different. They are the range you selected with your

mouse.]

Click on the next PASA exon in this evidence tier, “grab range” and repeat for the third exon. You should now have:
join(64173..66333,64830..65583,65639..65725,65768..66000)

Let’s now get rid of the approximate coordinates we chose in the beginning with our mouse.
join(64830..65583,65639..65725,65768..66000)

Click OK.
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Because this gene model was based on an EST
assembly, it may have untranslated regions (UTRs).
Determine the appropriate start and stop codons, if
possible (BLASTP is one way to do this). To trim it back
to the start and stop codons, right-click the model,
select Edit/Trim Selected Features/To Met. To extend
to the next stop codon, select Edit/Extend Selected
Features/To Previous Stop Codon or To Next Stop
Codon. In some cases, it is easier to visually identify the
coordinates of the stop codon and enter them in the
editor. In this case, the final coordinates would be
64830... 65811.

If you wish to add UTRs, follow the instructions in the
Genewise tutorial.

As time permits, continue to model genes.

Save them in the genes.gff3 file as you go.

1316.m000003: CDS . 2000010 3
[ [
genezilla model 1316.m000018 6.e000123,1316.e000123, cds_of_1316.m000019, cd
[ I

1316.m000015: CDS . e000097,1316. 2000098

P 1 P T D
evm.model.1316.12 CDS eym.mod eym.model.1316.12
b b 1
PASA. 182085 PASA. 18 PASA. 182085
[ 1
1316.m000078: CDS . e000365,1316. 000366
I | - - 1 8
DS Smallest Features In Front
[ P| Set Score Cutoffs ...
mat Undo - Raise Selected Features
T - © | Lower Selected Features
natch.gene: mat Zoom to Selection
match. genew nat Selected Features in Editor (tr1-E | select wisible Range
Subsequence (and Features) Select Visible Features
Find/Replace Qualifier Text ... Frame Line Features ...
@1800 bsooo Qualifier of Selected Feature(s) »| Entries 4
Selected Feature(s) )| Select »
i »
Move Selected Features To p| View
Copy Selected Features To ) i ’
v Edit »
Trin Selected Features Y| Create 4
Extend Selected Features M Write »
Fix Stop Codons Run »

Automatically Create Gene Names
Fix Gene Names
Bases )

Contig Reardering

Header Of Default Entry




